Jump to content
  • 0

Bluetooth printer won't print after restarting Chromebook


FolcodeJong
 Share

Question

For some reason, my bluetooth-printer (mC-Print 2, connected as mPop) won't keep a working connection with my Chromebook (HP x360 14-da0900nd).

When I pair the printer via bluetooth, and then add the printer in the Loyverse app, it works. But when I restart my chromebook it doens't connect anymore. It used to start working again when I turned Bluetooth off and on, but now I have to reinstall the printer for it to work.

I assume it has something to do with the way android-apps are allowed bluetooth access on chromebooks, but hopefully this can be solved in a future update? It should be possible, because the iZettle app doesn't have the same problem.

(btw. my android phone does not have the same problem either, it can always print without any extra steps.)

Link to comment
Share on other sites

5 answers to this question
Recommended Posts
  • 0
5 hours ago, retms said:

hi, maybe you had better ask in the official forum

https://support.google.com/chromebook/community?hl=en

Uhmm, that's the Chromebook forum, and it's a problem with how the Loyverse app works on Chromebooks, not about Chromebooks in general.

As I said, iZettle is able to use the printer, so it's not a Chromebook bug, but rather something that needs a different way of doing it in the Loyverse-app.

Edited by FolcodeJong
clarification
Link to comment
Share on other sites

  • 0

When I reread my post I understand why you responded with this.

What I meant was:

When I restart my Chromebook, Loyverse no longer prints on my bluetooth printer. My chromebook is still paired, but the app no longer seems to be able to make a connection. Even though iZettle is able to print on the same printer without extra steps, for Loyverse to be able to print I need to forget the printer, re-pair it, and reinstall in in the loyverse app. Then it works again untill I restart.

Edited by FolcodeJong
couldn't edit original question
Link to comment
Share on other sites

  • 0
14 hours ago, lcardinale said:

Does anyone is using a Lenovo Chrome book with a usb or bluetooth thermal printer? Mine does detect the usb printer in the chrome OS, but Loyverse does not detect any printer in the usb port

Hello, is your printer included in the list of recommended Loyverse?  

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Jrivera
      Is my SM-T300i mobile bluetooth printer compatible with Loyverse on my IOS device?
    • By Jrivera
      Ref: connecting a mobile bluetooth printer in the Loyverse app.
      In the Android version of the Loyverse app one can select an "Other" printer and "Bluetooth" connection. The printer works connected to Android devices. I need this functionality to be operational in the IOS version of the Loyverse app. In the IOS app (v10 user) we are not getting similar and flexible printer options for an Other/Bluetooth printer in the Loyverse app. The printer connects to the v10 IOS device and prints. But, the Loyverse app will not connect to the printer. Am I missing something and not seeing the Other/Printer options for IOS?
    • By Andrew de Freitas
      Hi,
       
      I've been looking at the bluetooth thermal printers on amazon.com
      A few of them say they don't support Android 7.0.
       
      Has anyone tried to get any of the inexpensive, portable, bluetooth printers working with the software?
      Thanks.
    • By MarcoSan
      Hello All,
      Do you know if the printer model XPrinter XP-N160II is compatible with Loyverse? Below you can see the technical details of the printer:
      Commands ESC/POS Ethernet (RJ45) 80mm paper width Best regards,
    • By Noterious
      I am currently using Zjiang ZJ-8250 (http://www.zjiang.com/en/init.php/product/index?id=36) with Loyverse in bluetooth mode. 
      The printer generally works fine, but it prints out gibberish every other receipt. Here is the sequence of the problems.
      1. First receipt, the printer prints out and do the auto cut just fine.
      2. Second receipt, the printer prints out until the last line of the receipt, but does not feed the receipt out and do the auto cut. (I have to manually pull and tear the receipt.)
      3. Third receipt, the printer prints gibberish and do not cut.
      The problem seems to be similar to this post: 

      https://loyverse.town/topic/2315-why-is-my-receipt-printer-printing-gibberish/#comment-4567

      (Similar in both problem and the printer itself.)
      However, I cannot set it to print in text mode as the thread suggested, because I need to print Thai characters. So, I am stuck with image mode.
      I have tried with a few esc/pos commands, like resetting the printer, line feed and such with no success. 
      I tried to find a way to change the printer code page to Thai so that I can try with text mode, but no luck. (Zjiang contact does not response, either.)
      Any suggestion would be greatly appreciated.

Loyverse Point of Sale

 

 

 

 

×
×
  • Create New...