Jump to content

Connecting to Sumup Devices issue

Go to solution Solved by Standtheman,

Recommended Posts

This is strange... we are using 3 iPads and 3 sumup devices. They are located in different areas of the shop (not next to each other). We've been using this setup for about 2-3 years if not more.

Today, a strange issue is happening, the sumup devices have been disconnected, and a message is coming onto the loyverse screen asking us to turn ON the bluetooth. But the bluetooth is turned ON. Our barcode scanner is bluetooth and is working good. The other strange thing is that the message appearing on screen is different on each iPad.

The devices are working with my separate sumup app on my phone. So I do not think the issue is with the devices. Like I said. It's 3 different iPads and 3 different sumup devices. I have tried removing the loyverse app from one of the iPads, and re-installing it, I have tried removing the sumup payment option from back office payment types and also tried logging out and back in again, and even tried resetting the sumup devices. Nothing works. So I'm guessing there is an issue either with one of the API's loyverse or sumup, or the loyverse programming connecting to the iPads bluetooth functionality.




Link to comment
Share on other sites


Thank you for your post.

The messages visible on the screen after selecting Sumup as the payment type are sent by Sumup.

Have you already tried contacting Sumup support?

Link to comment
Share on other sites

Hi Shinjin,

yes I have tried, with the online support. They are not so good. I have to email them to another department. We’ll see how long it takes.

I now think the problem is with the sumup API. But trying to explain what an API is to someone on low level support is not easy.

Link to comment
Share on other sites

Hi Shinjin, is it possiblele that the SumUp API used in loyverse needs updating? 

Link to comment
Share on other sites


Thank you for letting us know.

Our team is considering updating the Sumup SDK while also taking into account the potential disruption to the service such update might bring to users with older devices.

Please keep checking whether the Sumup team has replied to you and we will also try to investigate from our side.

Link to comment
Share on other sites

  • Solution

I am not exactly sure why it works, but I have managed to get them working again. I have never used the SumUp app on the iPads, because SumUp functionality was integrated into loyverse. As part of my troubleshooting, I installed SumUp app from iOS store to see if it would connect to the card readers. I was trying to eliminate any possible issue with iOS. YES! They could connect.

Now I knew there was no issue with the card readers or iOS. Then I tried going back to the loyverse app, but it still did not find the card readers, although I was now able to scan for other card readers. So I pressed the power button on the card reader for this iPad that I was working on to try to disconnect it from the SumUp app that I had just connected it too and then when I did a rescan in loyverse it worked. I was able to find the card reader for this iPad. 

I completed the same steps on the other two iPads and card readers, and I’m happy to say, they worked all day. Know I hope they continue to work next week.

I am guessing by installing the SumUp app and using it to connect to the card reader first, I was able to open some kind of port within iOS to the iOS Bluetooth function of he iPad. Just guessing, I don’t know how it all works exactly.

I hope this info can help someone else who has encountered a similar issue.

Thank you Shinjin for your responses.

  • Party 1
  • Thanks 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

Loyverse Point of Sale





  • Create New...