Jump to content

Epson TM-T20III


Recommended Posts

Hello everyone,

I wanted to inform the community that despite currently not being listed in the supported printer, the Epson TM-T20III (Ethernet) works perfectly on both iOS and Android.

We acquired this model because the Epson TM-T20II is not being produced anymore. As the Epson TM-T20III is the newest version which obviously supports support ESC/POS protocol, the fact that it worked seamlessly makes sense.



  • Select "Epson TM-T20II (Ethernet)" in the dropdown menu.
  • Despite being an Epson TM-T20III, Loyverse will automatically find the IP address.



  • Select "Epson TM-T20II (Ethernet)" in the dropdown menu.
  • Contrary to iOS, the IP address was not detected automatically and I had to enter it manually. It then worked perfectly.

@Loyverse Maybe something to update on the list of supported hardware? I guess this would help some people given that the Epson TM-T20II is not produced anymore, and they will likely find the Epson TM-T20III available for purchase instead.


La Cour

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

Loyverse Point of Sale





  • Create New...