Jump to content
  • 1
Cornerbarlipe

Xprinter Q200 bluetooth USB iOS iPad

Question

Hello,

I am using an xprinter Q200 printer via Bluetooth together with a Lenovo Android tablet. its working good but the tablet is old and slow.

I want to use an iPad air 2. i know this printer is not working over bluetooth with iPad because i tried it about 2 years ago.

but has anyone got it to work over USB with this printer and iPad?

Loyverse says the ESC/POS printer should work with iOS and Loyverse.

has anyone been successful with this?

Thank you

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 2

Unfortunately, this printer will not work with iOS.

For Bluetooth and USB interfaces, only models from recommended printers list with work with Loyverse POS on iOS.

For iOS devices, it is possible to try as other models only Ethernet printers, which fulfill requirements of supporting ESC/POS protocol.

  • partying face 1

Share this post


Link to post
Share on other sites
  • 1

Thank you for your info, 

So if I understand you correctly, this printer will not work under any circumstances  with iOS?

or are you saying that it might or might not work over Ethernet?

is there some development that can be done by Loyverse to make this printer work over Bluetooth with an iOS device in future? 
 

Thank you!

Share this post


Link to post
Share on other sites
  • 1

Only MFi certified devices are possible to connect with iOS devices via Bluetooth and USB interfaces.

Apple’s MFi Program (“Made for iPhone/iPod/iPad”) is a licensing program for developers of hardware and software peripherals that work with Apple’s iPod, iPad, iPad mini, and iPhone.

But even for MFi certified receipt printers, our Loyverse development team needs to have them and to integrate their work with Loyverse.  

It looks like the model Q200 USB does not complete with such requirements, so it cannot work with Loyverse.

Share this post


Link to post
Share on other sites

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Nativebreeze
      Hello everyone
      I would like to change the POS commands in the app to open the cash drawer. The command for my MUNBYN bluetooth printer is 27,112,0,50,250 , but LOYVERSE app will not allow the entry of more than 2 digits before a comma, 3 digits can not be entered before a comma. Any assistance is greatly appreciated. 
    • By Noterious
      I am currently using Zjiang ZJ-8250 (http://www.zjiang.com/en/init.php/product/index?id=36) with Loyverse in bluetooth mode. 
      The printer generally works fine, but it prints out gibberish every other receipt. Here is the sequence of the problems.
      1. First receipt, the printer prints out and do the auto cut just fine.
      2. Second receipt, the printer prints out until the last line of the receipt, but does not feed the receipt out and do the auto cut. (I have to manually pull and tear the receipt.)
      3. Third receipt, the printer prints gibberish and do not cut.
      The problem seems to be similar to this post: 

      https://loyverse.town/topic/2315-why-is-my-receipt-printer-printing-gibberish/#comment-4567

      (Similar in both problem and the printer itself.)
      However, I cannot set it to print in text mode as the thread suggested, because I need to print Thai characters. So, I am stuck with image mode.
      I have tried with a few esc/pos commands, like resetting the printer, line feed and such with no success. 
      I tried to find a way to change the printer code page to Thai so that I can try with text mode, but no luck. (Zjiang contact does not response, either.)
      Any suggestion would be greatly appreciated.
    • By Maslou
      Need help about printing for my next on a smartphone to terminal printer Bluetooth
    • By jason
      Can i buy a bluetooth printer in Hong kong?
    • By Peb94
      I have connected my printer to my android via Bluetooth in Loyverse settings and done a test print and it works fine! When I go to sales top right I normally am able to open cash drawer but option isn't there just synchronise, also in receipts where you can print a older receipt it just shows email receipt. It has been working fine but I deleted printer and tried to link it with another printer which had the same result and now when I try and reinstate the 1st printer I've had problems!
×
×
  • Create New...